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Annoyances 
Excel has many great features.  It also has some annoyances.  Two of the most common annoyances are 
the default setting of “personalized” menus, and the office assistant.   

Incomplete menus 
Have you ever wondered, “where did the 
rest of the menu go?”  If you are like most 
people, you have been trained long and hard 
to go to the menu to choose your 
options/actions.  We pick up the keyboard 
shortcuts for our most used actions, and rely 
on the menus to furnish the ones we haven’t 
yet committed to memory.   
 
Microsoft decided to play with the menus 
and have them list the most recently used 
ones, while hiding the infrequently choosen 
menu items.  All the items are there, you 
just need to click on the bottom of the menu 
to expand it to show all the menu items.   
 
When you go to the menu to find an 
option/action because it is one you don’t 
use often, and the only ones that appear on 
the menu are the ones you do use often,  

that’s annoying.  Fortunately, it’s easily remedied. 
You will find the fix under Tools/Customize on the Options tab.  Place a check in the “Always show full 
menus” box.  

Kill Clippie 

 
The default Office Assistant is Clippie, the 
animated paper clip. Some people think he’s 
cute, others would like him terminated with 
extreme prejudice.  If you are of the latter 
category of thought, right click on him the 
next time he appears and choose Options.  
The Office Assistant dialog box will appear.  
Uncheck the box next to Use the Office 
Assistant. 
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Bye, bye clippie! 
 
Of course, if you fall into the  
Pro Clippie camp, click on the gallery tab and 
choose your favorite character as your assistant.   
 
Click on OK to end. 
 
 
 
 
 
 

Working With Large Worksheets 
What is considered a large worksheet?  It all depends on what you are accustomed to.  A functional 
definition of a large worksheet is one where navigation within the sheet becomes cumbersome.   Excel 
can handle worksheets of up to 255 columns by 65,335 rows.  Now multiply that by 255, which is the 
maximum number of worksheets in a workbook, and you can really get lost.  The following are ways to 
help find your way around, 

Viewing 
When working with a spreadsheet, having more of it viewable is better.   Excel has several features and 
options which make it easy to increase your viewable area. 

Full Screen 
The easiest way is to 
use the full screen 
feature found under the 
View menu.  Simply 
choose View/Full 
Screen from the menu 
or use the keyboard 
shortcut <ALT> V, 
followed by U. 
 
 
  To exit the Full 
Screen view, click on 
the icon or use the 
<ALT> C keyboard 
combination to close 
and return to the 
normal view. 
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Turn off portions of Excel 
Tools/Options/View Under the View tab is the 
Show section.  By deselecting the options you 
gain more viewable screen area.   
  
By turning off the Formula and the Status bars, 
you gain a couple of rows of additional 
viewing area.  
 
 
  Other methods include turning off toolbars 
from the View/ Toolbars menu.  
 
 
 
 
 

 

Here is a view of 
Excel that is about as 
sparse are you can get 
and still function.   
 
Note the status bar at 
the bottom is gone, the 
formula bar is gone, 
and all the button style 
tool bars are gone. 
 
In this configuration 
we rely on the drop 
down menu system, 
quick menus, and “in 
cell” text and formula 
entry. 

The default toolbars 
are Standard, and 
Formatting. 
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Hiding the Task Bar 
In the Full Screen view, notice that the Task Bar is still being displayed.   
 
Did you know the task bar along the bottom of your screen can be made to 
disappear (at least temporarily)?  Windows has a way to make it hide when not 
in use, allowing a bit more of Excel (or any other application) to use that 
portion of the screen.  Find an empty space on the task bar and right click. 
 
 
 At the bottom of the quick menu click on Properties. 
 

 
 
 
 
 
On the Taskbar Options tab click in the checkbox next 
to Autohide.   Click on OK.  The taskbar will now be 
overlaid by any active application.  Move the cursor to 
the bottom of the screen and the taskbar will pop up 
automatically.   
 
 
 
 
 
 
 
 
 
 
 

Screen Resolution 
 
 
You maybe able to gain screen real estate by modifying your 
computer’s display resolution, if you are currently not at the highest 
resolution.   The quick way is to find an empty area on your 
desktop and right click to bring up a quick menu.  At the bottom 
select Properties.   
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A Display Properties box will appear.  Click on the 
Settings tab.  You will see a slider bar with the title 
“Screen Area” or “Screen Resolution” (depending on 
which version of Windows is on your machine). By 
clicking and dragging on the slider you can change the 
screen resolution.  Note  how the screen on the 
properties box changes.  Click on the Apply button.   
 
 
Your monitor may  blink or flicker for a moment and the 
stabilize at the new resolution.   If nothing appears, just 
wait 15 seconds and your previous resolution will be 
automatically restored. If the system does support the 
new setting, Windows will then ask if the new resolution 
is OK. 
 
 

 
 
 
If you click Yes, the new setting will stay.  Should you choose 
No, the system will revert to the previous resolution.  
 
 

 

Calculation Options 
Formulas are calculated automatically by 
default.  In certain instances where large 
amounts of calculations are being made, you 
may wish to turn off the automatic 
recalculation.  Waiting 10 to 20 seconds for 
recalculation after every change to the 
spreadsheet will test your patience.  
Fortunately, Excel allows you to turn off 
automatic calculations.  Found under the 
Tools/Options menu, the Calculation tab has 
several options allowing you to tailor its 
behavior.   By clicking on the manual button, 
you are in control of when the sheet 
recalculates.  To manually recalculate, simply 
press the <F9> function key.  You also have 
the option to force a recalculation when the 
file is saved. 
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Hiding Workbooks 
Hide and seek, Excel style. If you have simply too many 
workbooks open and it gets confusing keeping track of them, you 
can maintain a modicum of sanity by hiding the extraneous ones.  
Or you can drive yourself crazy by forgetting to unhide a 
spreadsheet.  It’s  your choice.  Here’s how:    
 
Have the window you wish to hide active.  From the Window 
menu choose Hide or use the <ALT> W, H keyboard shortcut.   
The active window is now hidden.  If it was the only workbook 
open, you will be staring at the blue background of raw Excel.  

 
To regain your hidden 
spreadsheet, choose 
Window/Unhide or use the keyboard shortcut of <ALT>W, U.   
 
TIP:  If you seem to be missing a workbook,, check the 
Windows menu.  If the Unhide button is NOT grayed out, there 
is a hidden workbook. 
 
 
 
 
 

Exercise: Hiding workbooks 
Exercise A 
Open the file K:\Excel\Intermediate.xls. 
 
Click on the Window menu item.  Next, select Hide.   
 
You should now see an empty Excel screen. 
 
Click on the Window menu item.  Next, select Unhide.  Note that Unhide is the only option not grayed 
out.  Select Intermediate from the Unhide Workbook pop-up window.  Click on OK. 
Intermediate.xls is back. 
 
Exercise B 
Open the files K:\Excel\Intermediate2.xls and K:\Excel\Intermediate3.xls. 
 
Click on the Window menu item. Select Intermediate from the bottom area of the drop down menu.  
This makes Intermediate the active workbook. 
 
Click on the Window menu item.  Next, select Hide.   
 
Click on the Window menu item. Select Intermediate2 from the bottom area of the drop down menu.  
This makes Intermediate2 the active workbook. 
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Click on the Window menu item.  Next, select Hide.   
 
For fun, place your cursor over the Excel Icon on the Taskbar. Click once.  Notice that only Intermediate3 
is shown. 
 
Click on the Window menu item.  Next, select Unhide.  Note that with multiple workbooks, Unhide is 
merely another menu selection.  
 
 Select Intermediate from the Unhide Workbook pop-up window.  Click on OK. 
 
Intermediate.xls is back. 
 
Click on the Window menu item.  Next, select Unhide. 
 
Select Intermediate from the Unhide Workbook pop-up window.  Click on OK. 
 
Intermediate.xls is back. 
 
For fun, place your cursor over the Excel Icon on the Taskbar. Click once.  Notice that all of our 
Intermediate excel files are shown. 

Freezing Panes 
Freezing portions of your screen is a very 
useful feature.  Excel calls it Freeze Panes.  
This allows you to “lock” things like row and 
column headings, which is handy for 
remembering what all those numbers really 
mean.  It’s an easy feature to use, as long as 
you remember it creates the frozen panes to 
the LEFT and ABOVE the active cell.  Freeze 
Panes is found on the Window menu or can be 
activated by the <ALT>W, F keyboard 
shortcut.  As you can see in the screen shots, 
cell B3 is active and Freeze Panes is being 
selected.  

 
 
 
 
Here you see the thin solid lines which demarcate the 
Freeze Panes.   Note that the lines are above and to the 
left of the active cell ,B3 . 
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Notice in this screen shot how the data has been 
scrolled, but the headings remain stationary (and 
visible!).  
 
 
To turn off the 
Freeze Panes 
choose Window, 
Unfreeze from the 
menu or use 
<ALT>W, F again 
to toggle the panes 
off. 
 
 
 

Exercises: Freeze! Don’t Move! 
 
In the Excel book Intermediate.xls, click on the Freeze tab to make it the active spreadsheet. 
 
Click once in cell C3 make it the active cell. 
 
From the Window menu, select Freeze Panes. 
 
Use the down arrow to scroll through the data. 
Next, use the right arrow to scroll to the right. 
Note the frozen portions of the screen do not scroll. 
 
Press the Scroll Lock key.  Excel is one application where it actually does something. 
Now, try scrolling again.  Notice that scrolling is immediate. 
 
Turn off Freeze Panes by going to the Window menu and selecting Unfreeze Panes. 

Arranging windows 
 
 
Excel can have multiple workbooks open at once.  Each workbook 
can have it’s own window displayed in Excel.  The number of 
workbooks Excel can open is limited by the memory and resources 
available on your computer.   Quite logically, the Arrange options 
are found on the Window menu. 
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The options are Tiled, Horizontal, Vertical, and Cascade.  Select the checkbox 
next to Windows of active workbook to view sheets only in the active 
workbook.  The following screen shots show each of the options with three 
workbooks open. 
 
 
 
 

Tiled        Horizontal 

Vertical       Cascaded 
 
Click on the maximize button to bring a worksheet to full size. 
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Multiple Views of the same workbook 
Have you ever wanted to 
have a window for each 
sheet in a workbook?  It is 
easy to do.  Simply open 
an new window for each 
sheet.  Notice the syntax of 
the name displayed in each 
window title bar: 
<Filename:Number>.  
Each new window gets a 
number. 

Just click on the tab you want to display in each window. 

Exercise: Multiple views 
 
In Intermediate.xls click on Window/New. 
 
Click on Window. 
Notice that at the bottom of the menu there are now two window names: Intermediate:1 and 
Intemediate:2. 
These are both the same worksheet, just another view. 
In Intermediate:1, click on the Formulas sheet tab. 
In cell F15 enter “Bob” 
In Intermediate:2, click on the Formulas sheet tab. 
Bob is there in cell F15. 
Delete Bob from cell F15. 
 

Compare Side by Side 
Once there is more than one window 
open, a new menu item is available.  
Compare Side by Side with… allows a 
quick method of comparing two 
workbooks.  When you select Compare 
Side by Side with… from the Window 
menu, the active workbook is 
automatically selected for the first of the 
workbooks.     
If  there are only two workbooks open, 
Compare Side by Side will list the non-active workbook in the menu 
and will not open a pop up box. 
 

If there are more than two workbooks open a pop up window containing a list of other open workbooks is 
presented for your choice of a second workbook. 
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Click on the desired workbook and click OK to do a side 
by side comparison.  The comparison stays active until 
you click on the Close Side by Side button.  Closing Side 
by Side returns you to the prior state of Excel.  It’s a 
quick and easy way to manipulate workbooks. 
 
 
 
 
 

 

 

 

Exercise: Compare Side by Side 
In file Intermediate.xls use File/Open from the menu to open Intermediate2.xls. 
  
From the Window menu, choose Compare Side by Side with Intermediate1xls. 
 
Go ahead and compare the two, click on tabs, switch back and forth between workbooks. 
 
Click on the Close Side by Side button. 
 
From the File menu select Open and choose Intermediate3.xls. 
 
From the Window menu, choose Compare Side by Side with… 
 
Notice that when there are more than two instances of workbooks open, a dialog box will pop up listing 
your choices. 
 
Select a workbook and click on OK to compare them Side by Side. 
 
Click on Close Side by Side to end the comparison and close the window. 
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Workspace 
A workspace file contains information about how a defined set of 
workbooks were arranged, including window sizes, screen magnification, 
display settings, and print areas.  It does NOT contain the 
Workbooks.   If you spend any amount of time getting your favorite 
spreadsheets laid out just the way you want them, save it as a workspace.  
 
 
 
From the File menu, select Save 
Workspace.  Type in a name or 
select one from the list.   
 
 
 
 
 

Exercise: Workspace 
Arrange the open workbooks the way you want them. 
From the File menu select Save Workspace.   
Enter a name for your workspace.  
Click on Save. 

Custom Fill Series 
Autofill automatically fills a series cells based on the contents 
of the initial cell.  The subsequent entries are pulled from a list, 
and wrap back to the beginning of the list if the range of 
selected cells is longer than the list.  The initial cell does not 
have to contain the initial list entry.  For example, if your 
custom autofill list were comprised of “Bob, Carol, Ted, Alice” 
And the initial cell contained “Ted” the autofill would fill the 
next cell with “Alice”, followed by “Bob”, then “Carol”, and 
back to “Ted” if the selected range were that long. 
 
Not to be confused with data lists, an autofill custom list in 
Excel is a specified sequence of text separated by commas .  
Excel has built in, ready to use autofill lists for the days of the 
week and the months of the year in both full and abbreviated 
formats.   You can also create a custom list.   
 
A custom autofill list can contain both text and numbers, 
however, the list must be created with numbers formatted as 
text.  Also, to use the numbers from the autofill list, the starting 
cell must be formatted as text.  In other words, it can be done, 
but you have to jump through a couple of hoops to get it done. 
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To create a custom autofill list start by choosing Tools/Options from the menu. 
 

Select the Custom Lists tab. 
 
There are two ways to enter a custom list.  The 
first is to click on NEW LIST in the Custom 
lists: window.  In the List entries window, 
enter the text items you want in the list, 
separated 
by 
commas.  
Click 
Add and 
enter the 
list. 

 
 
 
 
 
The second way is to import the list from a range of cells.  In this 
method, a range on cells is entered into the range field and the 
Import button is clicked. 
 
 
 

 
Exercise: Custom Lists 
Exercise A: 
 
Use the Intermediate.xls workbook and click on the CustomLists tab to make it active. 
From the Tool menu select Options. 
Click on the Custom Lists tab to make it active.   
Make sure the New List is highlighted (normally the top entry) in the Custom Lists area. 
In the List Entries area, enter Larry, Moe, Curly, Shemp, Joe, Curly Joe 
Click Add 
Note the new entries in the custom list area. 
 
Enter $C$5:$C$10 in the Import from cells box. 
Click on Import.   
Click on OK. 
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In cell E4 enter larry. 
Using the fill tab at the lower left corner of cell E4, click and drag to highlight cells E4 through G4. 
Release the mouse button.    
Larry, Moe, Curly will be cells E4 through G4 respectively. 
 
Next, click in cell C5.  Again, use the fill tab at the lower left corner of the cell to click and drag 
highlighting cells C5 through H5.  The stooge’s names will be displayed. 
 
 In cell D14 enter Shemp.  
Using the fill tab at the lower left corner of cell D14, click and drag to highlight cells D14 through G14. 
Release the mouse button.    
Notice that you can start anywhere in the custom list and it will recognize it. 
 
 

Concatenation of Cells 
Let’s suppose you have a column of last names, and a column of first names.   Also, you would like to 
create a new column with both the first and last name combined in to a single cell.  With numbers, you 

would add the cells together.  With text you use the concatenate 
function.  Up to 30 text strings can be made into one. 
 
Select Function from 
the Insert menu.  The 
Insert Function dialog 
box will appear.  You 
can Search for a 
function, select a 
function category, or 
select a function from 
a list.  
 
 Here the Text 
category is selected. 
Select Concatenate and 
click on OK.   

 
 
 
Next, we select the text we want to combine.  
The first is in cell C4 which contains “Barney”. 
The second is a literal string of a single space 
enclosed in quotes.  This puts a space between 
the first and last names.  Last, cell B4 which 
contains “Rubble” is entered.   Note the 
proposed result.  If this is what you want, click 
on OK. 
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 Here is the result. 
 
 
 
 
 
 
 
 

 
 
 
 
As with most things in Excel, there is more than one 
way to do something.  The ampersand (&) functions 
as concatenate in a formula.  Typing  =C4&” “&B4 
gives the exact same result as going through the 
insert function menus.     

 

 
Exercise:  Concatenation 
 
In Intermediate.xls click on the Concatenation tab to make it the active tab. 
 
In cell E4 enter the following formula =C4&” “&B4 
Press Enter. 
Note the entry in cell E4 now displays Barney Rubble. 
 
Right click in cell E4 and select Copy from the quick menu. 
Click and drag from cell E5 to cell E9 highlighting those cells.   
Right click anywhere in highlighted area and select Paste from the quick menu. 
The formula is copied from cell E4 and copied into the range E5 to E9. 
 
Suppose the desired result is not first and last name, but last name, comma, first name. 
 
In cell F4 enter the following formula =B4&”, “&C4 
Press Enter. 
Note the entry in cell F4 now displays Rubble, Barney. 
 
Click in cell F4 and use the grab tab in the lower right corner to highlight the range of cell F4 to F9. 
The formula from cell F4 is copied into the range F4 to F9.  Neat, eh? 
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Cell References 
Even Excel needs good references. What are references?  References are the way in which Excel is able to 
locate a cell or range of cells in a spreadsheet.  There are two way in which cells are referenced in a 
spreadsheet, relative and absolute. 
 
 Relative References 
 A formula created with relative references uses the active cell as its base point.  
All of the formula references are relative to that point.   The beauty of relative references is you can copy 
and paste the formula without having to enter the cell references, the references adjust automatically.  A 
relative reference takes the form of column, row.  For example, A1 is the relative reference for the cell at 
the intersection of column A and row 1. 
 
Absolute References 
Absolute references refer to a specific row, column, or cell of a spreadsheet.  Absolute references are 
denoted by using the dollar sign immediately before the column and row to lock in the row, column or 
both.   For example $A$1  is the absolute reference for the cell at the intersections of  column A, row 1. 

 

Names 
 A word or string of characters that represents a cell, range of cells, formula, or constant value. Use easy-
to-understand names, such as Products, to refer to hard to understand ranges, such as Sales!C20:C30. 
 
 

Names in Formulas 
You can use the labels of columns and rows on a worksheet to refer to the cells within those columns and 
rows. Or you can create descriptive names to represent cells, ranges of cells, formulas, or constant values.  

Note: Labels can be used in formulas that refer to data on the same worksheet; if you want to represent a 
range on another worksheet, use a name. 

A defined name in a formula can make it easier to understand the purpose of the formula. For example, 
the formula =SUM(FirstQuarterSales) might be easier to identify than =SUM(C20:C30). 

Names are available to any sheet. For example, if the name ProjectedSales refers to the range A20:A30 on 
the first worksheet in a workbook, you can use the name ProjectedSales on any other sheet in the same 
workbook to refer to range A20:A30 on the first worksheet. 

Names can also be used to represent formulas or values that do not change (constants). For example, you 
can use the name SalesTax to represent the sales tax amount (such as 6.2 percent) applied to sales 
transactions. 

You can also link to a defined name in another workbook, or define a name that refers to cells in another 
workbook. For example, the formula =SUM(Sales.xls!ProjectedSales) refers to the named range 
ProjectedSales in the workbook named Sales. 

Note  By default, names use absolute cell references. 
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Rules for names 

A name can contain up to 255 characters.The first character of a name must be a letter or an underscore 
character. Remaining characters in the name can be letters, numbers, periods, and underscore characters.   
Names as NOT case sensitive.  Names cannot be the same as a cell reference, such as Z$100 or R1C1, 
that would confuse Excel (and be redundant).  Underscore characters and periods may be used as word 
separators— for example, Sales_Tax or First.Quarter. 

Note  If a name defined for a range contains more than 253 characters, you cannot select it from the 
Name box. 

Using existing row and column labels as names 

When you create a formula that refers to data in a worksheet, you can use the column and row labels in 
the worksheet to refer to the data. For example, to calculate the total value for the Product column, use the 
formula =SUM(Product). 

 
 

Cell Naming 

Name cells in a workbook 
You can use the labels of columns and rows on a worksheet to refer to the cells within those columns and 
rows. Or you can create descriptive names to represent cells, ranges of cells, formulas, or constant values. 
Labels can be used in formulas that refer to data on the same worksheet; if you want to represent a range 
on another worksheet, use a name. 
Names that are used across two or more worksheets are called 3-D names. 
 

 
 
 
Define – Where you add, delete and modify names 
Paste – Paste existing names into new places 
Create -- (Create names from copied cells?) 
Apply --  Applies names to existing formulas, cells 
Label --  Use a label instead of a name  
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Change cell references in formulas to names 

If you define names for cell references after creating one or more formulas that use those cell references, 
you can update those cell references to names. 

Do one of the following:  
To update only certain formulas on a worksheet, select the cells that contain those formulas.  
To update all the formulas on the worksheet, select a blank cell. 
On the Insert menu, point to Name, and then click Apply.  
In the Apply names box, click one or more names. 
 
 

Exercise: Name a range of cells 
In worksheet Intermediate.xls click on the Names worksheet tab to select it. 
 
In cell B4, click and drag to cell B7. 
 
From the Insert menu select Names, then Define. 
In the Names in Workbook area, enter the name for your data range. 
In the Refers to: area, enter the cell or range of cells you wish to name.  
Click Add to enter the name for the range.   
Click on Names in Workbook, enter Expenses. 
In the Refers to: area click on the range selection tool. 
Click and drag from C4 to C7.  Press enter. 
Click on Add. 
 
Click OK to accept the names. 
 
In cell D4 enter =income-expenses 
 

Custom Formats 
 
 
Custom Formats allow you to specify exactly how you 
want to display a number, date or time, currency, 
percentage, scientific notation, and text or spacing. 
 
 Specify up to four sections of format codes.  
Separate the sections with a semicolon.  The order of the 
sections is as follows, positive number, negative number, 
zeros, and text.   If you enter only two sections, the first 
will be applied to positive and zeros, the second to 
negatives.  If only one is specified, it will be applied to 
all numbers.  In the case where you wish to skip a section, 
simply enter a semicolon as it’s placeholder. 
 
To display both text and numbers in a cell,  enclose the 
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text with double quotes.  A single character should be preceded by a backslash.  Special characters are 
displayed without the use of  quotation marks: $ - +  /  ( )  :  | ^ & `(left single quote) ‘ (right single quote)  
~ { } = < > and the space character. 
 
A section for text entry.  A text entry section is always the last section in the number format.  Include an 
at (@) sign in the section where you want the text to be displayed.  If the @ is missing, so will be the text.    
If you want to display specific characters along with the entered text, simply enclose the additional text 
within double quotes, then the @ symbol. 
 
Adding a space for alignment of numbers.  To create a space the width of a character, include an 
underscore followed by the character.  

Create a custom number format 

1. Select the cells you want to format.  
2. On the Format menu, click Cells, and then click the Number tab.  
3. In the Category list, click a category that is similar to the one you want, and then set its built-in 

formats to be similar to the ones you want. (You will not alter the built-in format; you'll be creating a 
copy to customize.)  

4. In the Category list, click Custom.  
5. In the Type box, edit the number format codes to create the format you want.  

You can specify up to four sections of format codes. The format codes, separated by semicolons, 
define the formats for positive numbers, negative numbers, zero values, and text, in that order. If you 
specify only two sections, the first is used for positive numbers and zeros, and the second is used for 
negative numbers. If you specify only one section, it is used for all numbers. If you skip a section, 
include the ending semicolon for that section. 

 
Use format codes that describe how you want to display a number; date or time; currency, percentage, 
or scientific notation; and text or spacing. 

Displaying both text and numbers    To display both text and numbers in a cell, enclose the text 
characters in double quotation marks (" ") or precede a single character with a backslash (\). Include 
the characters in the appropriate section of the format codes. For example, type the format $0.00" 
Surplus";$-0.00" Shortage" to display a positive amount as "$125.74 Surplus" and a negative 
amount as "$-125.74 Shortage." The following characters are displayed without the use of quotation 
marks: $ - + / ( ) : ! ^ & ' (left single quotation mark) ' (right single quotation mark) ~ { } = < > and 
the space character. 

Including a section for text entry    If included, a text section is always the last section in the number 
format. Include an at sign (@) in the section where you want to display any text entered in the cell. If 
the @ character is omitted from the text section, text you enter will not be displayed. If you want to 
always display specific text characters with the entered text, enclose the additional text in double 
quotation marks (" ")— for example, "gross receipts for "@ 

If the format does not include a text section, text you enter is not affected by the format. 
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Adding space    To create a space the width of a character in a number format, include an underscore 
(_) followed by the character. For example, when you follow an underscore with a closing parenthesis 
(_)), positive numbers line up correctly with negative numbers that are enclosed in parentheses. 

Repeating characters    To repeat the next character in the format to fill the column width, include an 
asterisk (*) in the number format. For example, type 0*- to include enough dashes after a number to 
fill the cell. 

Decimal places, spaces, colors, and conditions 

Decimal places and significant digits    To format fractions or numbers with decimal points, include 
the following digit placeholders in a section. If a number has more digits to the right of the decimal 
point than there are placeholders in the format, the number rounds to as many decimal places as there 
are placeholders. If there are more digits to the left of the decimal point than there are placeholders, 
the extra digits are displayed. If the format contains only number signs (#) to the left of the decimal 
point, numbers less than one begin with a decimal point. 

• # displays only significant digits and does not display insignificant zeros.  
• 0 (zero) displays insignificant zeros if a number has fewer digits than there are zeros in the 

format.  
• ? adds spaces for insignificant zeros on either side of the decimal point so that decimal 

points align when formatted with a fixed-width font, such as Courier New. You can also use ? for 
fractions that have varying numbers of digits.  

To display Use this code 

1234.59 as 1234.6 ####.# 

8.9 as 8.900 #.000 

.631 as 0.6 0.# 

12 as 12.0 and 1234.568 as 1234.57 #.0# 

44.398, 102.65, and 2.8 with aligned decimals ???.??? 

5.25 as 5 1/4 and 5.3 as 5 3/10, with aligned division symbols  
# ???/??? 

 
Thousands separator    To display a comma as a thousands separator or to scale a number by a multiple 
of one thousand, include a comma in the number format.  
 

To display Use this code 

12000 as 12,000 #,### 

12000 as 12 #, 

12200000 as 12.2 0.0,, 

 
Color    To set the color for a section of the format, type the name of one of the following eight colors in 
square brackets in the section. The color code must be the first item in the section.  
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[Black] [Blue] 

[Cyan] [Green] 

[Magenta] [Red] 

[White] [Yellow] 

 
Conditions    To set number formats that will be applied only if a number meets a condition you specify, 
enclose the condition in square brackets. The condition consists of a comparison operator (comparison 
operator: A sign that is used in comparison criteria to compare two values. Operators include: = Equal to, 
&gt; Greater than, &lt; Less than, &gt;= Greater than or equal to, &lt;= Less than or equal to, and 
&lt;&gt; Not equal to.) and a value. For example, the following format displays numbers less than or 
equal to 100 in a red font and numbers greater than 100 in a blue font.  
[Red][<=100];[Blue][>100] 
To apply conditional formats (conditional format: A format, such as cell shading or font color, that Excel 
automatically applies to cells if a specified condition is true.) to cells— for example, color shading that 
depends on the value of a cell— use the Conditional Formatting command on the Format menu. 
Currency, percentages, and scientific notation 
Currency symbols    To enter one of the following currency symbols in a number format, turn on NUM 
LOCK and use the numeric keypad to enter the ANSI code for the symbol. 
 

To enter Hold down ALT and type this code

¢ 0162 

£ 0163 

¥ 0165 

 0128 
Note  Custom formats are saved with the workbook. To have Microsoft Excel always use a specific 
currency symbol, change the currency symbol selected in Regional Settings in Control Panel before you 
start Excel. 
Percentage    To display numbers as a percentage of 100, include the percent sign (%) in the number 
format. For example, a number such as .08 appears as 8%; 2.8 appears as 280%. 
Scientific notation    To display numbers in scientific format, use "E-," "E+," "e-," or "e+" exponent 
codes in a section. If a format contains a zero (0) or number sign(# ) to the right of an exponent code, 
Excel displays the number in scientific format and inserts an "E" or "e". The number of zeros or number 
signs to the right of a code determines the number of digits in the exponent. "E-" or "e-" places a minus 
sign by negative exponents. "E+" or "e+" places a minus sign by negative exponents and a plus sign by 
positive exponents. 
Dates and times 
Days, months, and years    If you use "m" immediately after the "h" or "hh" code or immediately before 
the "ss" code, Microsoft Excel displays minutes instead of the month. 

To display Use this code

Months as 1–12 m 

Months as 01–12 mm 
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Months as Jan–Dec mmm 

Months as January–December mmmm 

Months as the first letter of the month mmmmm 

Days as 1–31 d 

Days as 01–31 dd 

Days as Sun–Sat ddd 

Days as Sunday–Saturday dddd 

Years as 00–99 yy 

Years as 1900–9999 yyyy 

Hours, minutes, and seconds  

To display Use this code 

Hours as 0–23 H 

Hours as 00–23 hh 

Minutes as 0–59 m 

Minutes as 00–59 mm 

Seconds as 0–59 s 

Seconds as 00–59 ss 

Hours as 4 AM h AM/PM 

Time as 4:36 PM h:mm AM/PM

Time as 4:36:03 P h:mm:ss A/P 

Elapsed time in hours; for example, 25.02 [h]:mm 

Elapsed time in minutes; for example, 63:46 [mm]:ss 

Elapsed time in seconds [ss] 

Fractions of a second h:mm:ss.00 

AM and PM    If the format contains an AM or PM, the hour is based on the 12-hour clock, where "AM" 
or "A" indicates times from midnight until noon and "PM" or "P" indicates times from noon until 
midnight. Otherwise, the hour is based on the 24-hour clock. The "m" or "mm" code must appear 
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immediately after the "h" or "hh" code or immediately before the "ss" code; otherwise, Microsoft Excel 
displays the month instead of minutes.  

Note  You can also use the & (ampersand) text operator  to join, or concatenate, two values. 

 
Repeating characters.  To fill the column width with a character, include an asterisk followed by the 
character. 
 

Exercise: Create a Custom Format 
 
Exercise A: Green is good 
Let’s make a sale of over 2,750 or over appear as green text. 
 
In Intermediate2.xls 
Click on the Custom Formats tab to make it the active sheet. 
In cell D5 click and drag to cell D7 to highlight the range. 
Right click anywhere in the highlighted range to bring up the quick menu. 
From the quick menu select Format Cells. 
In the Number tab, in the Category area select Custom (it should be at the bottom of the list). 
Under the Type area, scroll down until you see the formatting codes that match $#,##0_);($#,##0) 
Click once on it to highlight it. 
In the Type are we can now edit the format to suit our needs. 
Edit the formatting codes to match [Green][>=2750] $#,##0_);$#,##0 
This tells Excel to make the text green if the value is equal to or greater than 2750, otherwise format it as 
normal currency. 
 
Click on OK. 
 
Notice that Larry with sales of $3,000 stands out with green text. 
Click in cell D7 and enter 2788. 
Now Curly is in green. 
 
Exercise B: Leading zeros 
Decimal and Binary numbers. 
In instances where leading zeros are important as placeholders or for other reasons, we can make Excel 
display the leading zeros by using a custom format. 
 
In Intermediate2.xls, on the Custom Format sheet, Click on cell D11 and drag to cell D26 to select the  
range.   
Right click anywhere on the range to bring up the quick menu. 
From the quick menu select Format Cells. 
In the Number tab, in the Category area select Custom (it should be at the bottom of the list). 
In the Type area, enter four zeros. 
Click on OK. 
Notice the leading zeros appear. 
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Formula Creation 
 
The heart of Excel (or any spreadsheet) is formulas.  A formula is an equation that performs calculations 
on data in your spreadsheet.  A formula starts with an equals sign. “=”.  Calculations are made on 
numbers, values contained in cell references, named values, or values derived from other formulas or 
functions.     
 

 
Here is an example of a simple 
formula: =35+40.  If you enter 
this formula into a cell in your 
spreadsheet, you will see the 
result of the formula (75) 
displayed in the cell.  Notice 
the formula in the Formula bar. 
 
 
 
 
 

 

Operators  
Operators are the familiar addition, subtraction, multiplication, division, percent and exponentiation (+,-
,*,/, %, and ^ ).Operators specify the type of calculation that you want to perform on the elements of a 
formula. Microsoft Excel includes four different types of calculation operators: arithmetic, comparison, 
text, and reference. 
 
Arithmetic operators    To perform basic mathematical operations such as addition, subtraction, or 
multiplication; combine numbers; and produce numeric results, use the following arithmetic operators. 
 
Comparison operators    You can compare two values with the following operators. When two values 
are compared by using these operators, the result is a logical value either TRUE or FALSE. 
 
Comparison operator Meaning (Example) 

= (equal sign) Equal to (A1=B1) 

> (greater than sign) Greater than (A1>B1) 

< (less than sign) Less than (A1<B1) 

>= (greater than or equal to sign) Greater than or equal to (A1>=B1)

<= (less than or equal to sign) Less than or equal to (A1<=B1) 

<> (not equal to sign) Not equal to (A1<>B1) 
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Text concatenation operator    Use the ampersand (&) to join, or concatenate, one or more text strings to 
produce a single piece of text. 

Text operator Meaning (Example) 

& 
(ampersand) 

Connects, or concatenates, two values to produce one continuous text value 
("North"&"wind") 

 

Reference operators    Combine ranges of cells for calculations with the following operators. 

Reference 
operator Meaning (Example) 

: (colon) Range operator, which produces one reference to all the cells between two references, 
including the two references (B5:B15) 

, (comma) Union operator, which combines multiple references into one reference 
(SUM(B5:B15,D5:D15)) 

(space) Intersection operator, which produces on reference to cells common to the two 
references (B7:D7 C6:C8) 

 

Order of precedence 
If you combine several operators in a single formula, Excel performs the operations in the order shown in 
the following table. If a formula contains operators with the same precedence— for example, if a formula 
contains both a multiplication and division operator— Excel evaluates the operators from left to right. 

Operator Description 

: (colon)  

(single space) 

, (comma) 

Reference operators 

– Negation (as in –1) 

% Percent 

^ Exponentiation 

* and / Multiplication and division 

+ and – Addition and subtraction 

& Connects two strings of text (concatenation)

= < > <= >= <> Comparison 
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To change the order of evaluation, enclose in parentheses the part of the formula to be calculated first. For 
example, the following formula produces 11 because Excel calculates multiplication before addition. The 
formula multiplies 2 by 3 and then adds 5 to the result. 

=5+2*3 

In contrast, if you use parentheses to change the syntax, Excel adds 5 and 2 together and then multiplies 
the result by 3 to produce 21. 

=(5+2)*3 

In the example below, the parentheses around the first part of the formula force Excel to calculate B4+25 
first and then divide the result by the sum of the values in cells D5, E5, and F5. 

=(B4+25)/SUM(D5:F5) 

Entering Formulas 
Formulas are equations that perform calculations on values in your worksheet. A formula starts with an 
equal sign (=). For example, the following formula multiplies 2 by 3 and then adds 5 to the result: 

=5+2*3.  

Example formula What it does 
=128+345  Adds 128 and 345 
=5^2   Squares 5 
 
To create a simple formula: 

1. Click the cell in which you want to enter the formula.  
2. Type = (an equal sign).  
3. Enter the formula.  

Press ENTER. 

The following formulas contain of other cells. The cell that contains the formula is known as a dependent 
cell when its value depends on the values in other cells. For example, cell B2 is a dependent cell if it 
contains the formula =C2. 

 

Example formula What it does  

=C2 Uses the value in the cell C2 

=Sheet2!B2 Uses the value in cell B2 on Sheet2 

=Asset-Liability Subtracts a cell named Liability from a cell named Asset

Click the cell in which you want to enter the formula.  
In the formula bar  , type = (equal sign).  
Do one of the following:  
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To create a reference, select a cell, a range of cells, a location in another worksheet, or a location in 
another workbook. You can drag the border of the cell selection to move the selection, or drag the corner 
of the border to expand the selection.  

 
To enter a reference to a named range, press F3, select the name in the Paste name box, and click OK.  
Press ENTER.  

Conditional Operators 
Conditional operators in a formula allow you to use logical constructs in the formula.  Logical constructs 
are a way of introducing decision making into your formulas.    

You can use the AND, OR, NOT, and IF function to create conditional formulas. The IF function uses the 
following arguments: 

=IF(logical_test, value_if_true, value_if_false) 

Formula with the IF function 

 logical_test: the condition you want to check 
 value_if_true: the value to return if the condition is true 
 value_if_false: the value to return if the condition is false 
 
Create a conditional formula that results in a logical value (TRUE or FALSE) 
Use the AND, OR, and NOT functions, and operators (operator: A sign or symbol that specifies the type 
of calculation to perform within an expression. There are mathematical, comparison, logical, and 
reference operators.) to do this task, as presented in the following example worksheet. 
 

   

1 

2 

3 

4  

A 

Data 

15 

9 

8 

Formula Description (Result) 

=AND(A2>A3, A2<A4) Is 15 greater than 9 and less than 8? (FALSE)

=OR(A2>A3, A2<A4) Is 15 greater than 9 or less than 8? (TRUE) 

=NOT(A2+A3=24) Is 15 plus 9 not equal to 24? (FALSE) 
 

Create a conditional formula that results in another calculation, or values other than TRUE or FALSE 

Use the IF, AND, and OR functions to do this task, as presented in the following example worksheet. 

   

1 

A 

Data 
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2 

3 

4  

15 

9 

8 

Formula Description (Result) 

=IF(A2=15, "OK", "Not OK") If the value in cell A2 equals 15, then return "OK". 
(OK) 

=IF(AND(A2>A3, A2<A4), "OK", "Not 
OK") 

If 15 is greater than 9 and less than 8, then return 
"OK". (Not OK) 

=IF(OR(A2>A3, A2<A4), "OK", "Not 
OK") 

If 15 is greater than 9 or less than 8, then return "OK". 
(OK) 

 
Tip: A quick way to see the formulas in the worksheet rather than the results, is to use the <CTRL> ~ 
(control and tilde) to see the formulas and bring up the formula auditing toolbar.  
 

Exercises: Formulas 
 
Exercise A: 
Formula creation: Interview ratios 
In Intermediate.xls, click on the Formulas tab to select sheet. 
In cell E5, enter the formula =C5/B5 
In cell F5, enter the formula =D5/B5 
 
In cell G5, enter the formula =D5/C5 
 
Copy the formulas to fill out the table. 
 
Formula creation: Sales 
 
In cell E14, enter =($B$14*C14)*D14 
 
Copy the formula in E14 to the range E15:E19 
Notice the absolute reference to cell B14 does not change.   
 
 
Exercise B: 
Text formulas 
In Intermediate.xls, on the Formulas sheet, 
Click on cell C21 to select it. 
Enter the following formula =find(“ “,B21) 
Note that the number 7 is displayed in cell C21.  The find function found the space at the 7th position in 
the cell referenced. 
 
Next. Let’s edit the formula we just entered in cell C21. 
With C21 active, press <F2> to enter edit mode. 
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Move the insertion point to the right of the = and enter left(B21, 
Move to the end of the formula and enter a right closing parenthesis “)”. 
Press Enter to finish the formula.  Cell C21 now contains “George”. 
The left function returned the left 7 characters of the text string in cell B21. 
 
Exercise C:  
Conditional formulas 
 
Conditional formulas test if a specified condition is true. 
If true, return the first, if false return the second. 
 
In cell C27, enter the formula =if(b27>$a$27,”Yes”,”No”) 
 
Copy the formula from C27 to the range C29:C31. 
 
Note the answers in column C. 
 
In cell B27, enter the number 25. 
Note the changes in column C. 
 
In cell B7, enter the number 72. 
Note the changes in column C. 
 

Functions 
Functions are built-in formulas that takes a value or values, performs operations or calculations, and 
returns the resulting value or values.   Think of them as shortcuts to common formulas. Functions are 
useful in shortening lengthy formula and improve readability and ease of use.  Really.   Excel has over 
300 built-in functions (329 to be exact).  If that’s not enough, you can also define your own functions. 

 
 

Function appears on the Insert menu.  Another way 
is to click on the Fx immediately to the left of the 
the formula bar.  Alternatively, once you’re familiar 
with your favorite functions, you can enter them 
directly into a cell from the formula bar.   

 

 

 

Example formula  What it does
=SUM(A:A)   Adds all numbers in column A 
=AVERAGE(A1:B4)  Averages all numbers in the range 

Click the cell in which you want to enter the formula.  
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To start the formula with the function, click Insert 
Function on the formula bar (formula bar: A bar at the 
top of the Excel window that you use to enter or edit 
values or formulas in cells or charts. Displays the 
constant value or formula stored in the active cell.) 

.  
Select the function you want to use. You can enter a 
question that describes what you want to do in the Search 
for a function box (for example, "add numbers" returns 
the SUM function), or browse from the categories in the 
Or Select a category box. 
 
 

Enter the arguments. To enter cell 
references as an argument, click Collapse 
Dialog to temporarily hide the dialog 
box. Select the cells on the worksheet, 
then press Expand Dialog .  

When you complete the formula, press 
ENTER.  

 

 
 
 
 
 
Tip: You can quickly enter the same formula 
into a range of cells. Select the range you want 
to calculate, type the formula, and then press 
CTRL+ENTER. For example, if you type 
=SUM(A1:B1) in range C1:C5, and then press 
CTRL+ENTER, Excel enters the formula in each 
cell of the range, using A1 as a relative 
reference. 
 

 
If you are familiar with the arguments of a function, you can use the function tooltip that appears after you 
type the function name and an opening parenthesis. Click the function name to view the Help topic on the 
function, or click an argument name to select the corresponding argument in your formula. To hide the 
function tooltips, on the Tools menu, click Options, and then clear the Function tooltips check box on 
the General tab. 
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Exercise: Using Functions 
 
In Intermediate2.xls, click on the Functions tab to make the sheet active. 
In cell B10, enter =sum(b7:b9)  
The sum of the values in the range B7 to B9 is displayed in cell B10 
 
In cell C10, enter =avg(c7:c9) 
The average of the values in the range C7 to C9 is displayed in cell C10 
 
In cell D7, enter =sin(B7) 
The sine of  the value of B7 is displayed in D7. 
 
In cell E7, enter =count(B7:B9) 
The count function counts the number of number values in the specified range. 
Change the entry in E7  to =count(B6:B9) 
The expanded range includes the text “Sum”.  Note that the count in E7 did not change. 
 
In cell F7, enter =today() 
Today’s date will appear. 
 
In cell G7, enter =sum(B6:B9)/count(B6:B9) 
 
In cell H7, enter =roman(G7) 
Now we know what the mean is in roman numerals.  (The roman function works for number 1 through 
3999 only. A zero shows up as an empty cell.  If a number is larger than 3999, or negative, it returns a 
#VALUE error). 

Printing 
Printing in Excel can be a frustrating experience.  Here are some tips to help you get the information you 
need out of Excel and onto paper. 

Page Setup 
Page setup is where Excel look to find information about how the page is laid out. 
 

To print a spreadsheet on one or more 
pages 
Under Scaling, click Fit to.  
Do one of the following:  
Print a worksheet to fit a paper width 
In the first box beside Fit to, enter 1 (for 1 page 
wide).  
In the second box beside Fit to, delete the value 
so that the number of pages tall is unspecified. 
Print a worksheet on a specified number of pages 
In the boxes beside Fit to, enter the number of 
pages on which you want to print the work. 
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Note:Microsoft Excel ignores manual page breaks when you use the Fit to option.  
 
Print row and column headings or 
labels on every page 
Row headings are the row numbers to the left of 
the worksheet; column headings are the letters or 
numbers that appear at the top of the columns on 
a worksheet.  Sometimes it’s helpful to have 
them printed on each page.  Here’s how: 
 
Click the worksheet.  
On the File menu, click Page Setup, and then 
click the Sheet tab.  
Do one of the following:  
Print row and column headings 
Select the Row and column headings check 
box, and click Print.  

Print row and column labels on every page 
To print column labels on every page, under Print titles in the Rows to repeat at top box, enter the rows 
that contain the column labels, and then click Print.  
To print row labels on every page, under Print titles in the Columns to repeat at left box, enter the 
columns that contain the row labels, and then click Print. 

Defining the print area 
(print area: One or more ranges of cells that you designate to print when you don't want to print the entire 
worksheet. If a worksheet includes a print area, only the print area is printed.) 

Print Preview 
 Print preview commands 
 
Next  Displays the next page to be printed. If you 
have multiple worksheets selected and click Next 
when the last page of a selected worksheet appears, 
Excel displays the first page of the next selected 
worksheet. 
 
Previous   Displays the previous page to be 
printed. If you have multiple worksheets selected 
and click Previous when the first page of a selected 
worksheet appears, Excel displays the last page of 
the previous selected worksheet. 
 
 
 
 
 
 
Zoom   Switches between a full-page view of a 
sheet and a magnified view. The Zoom feature does 
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not affect printing size. You can also switch between a full-page view and a magnified view of a 
worksheet by clicking any area of the worksheet. Depending on the resolution of your monitor, you may 
not see certain graphics, such as thin borders, in full-page view.  
Print  Lets you set printing options and then prints the selected worksheet.  
Setup  Lets you set options that control the appearance of printed sheets.  
Margins   Displays or hides margin handles that you can drag to adjust page margins , header and footer 
margins, and column widths. 
Page Break Preview   Switches to page break preview, in which you can adjust the page breaks on the 
active worksheet. You can also resize the print area and edit the worksheet. The name of the button 
changes from Page Break Preview to Normal View if you were in page break preview when you clicked 
Print Preview . 
Normal View Displays the active worksheet in normal view. 
Close  Closes the print preview window and returns to the previous view of the active worksheet. 

Printing selected portions 
 Define what part of the worksheet to print 
On the View menu, click Page Break Preview.  
Select the area you want to print.  
On the File When you save the document, your print area selection is also saved. 
menu, point to Print Area, and then click Set Print Area.  
 
Add cells to an existing print area 
On the View menu, click Page Break Preview.  
Select the cells you want to add to the print area.  
Right-click within the selection, and then click Add to Print Area.  
 
On the File menu, point to Print Area, and click Clear Print Area. 
 
To return to normal view, go to the View menu and select Normal. 
 

Printing to a File 
 

 
Printing to a file is easy in Excel.  
From the File/Print menu selection, the Print dialog 
box appears.  Check the box next to Print to File. 
 
Another popup box will appear with the title Print To 
File.  Enter a name for your printout in the  
Output File Name 
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This concludes Intermediate Excel 2003 
 
 
If you have any questions, contact either myself or the computing helpdesk at 763-7699. 
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Worksheet and workbook specifications 
 

Feature Maximum limit 

Open workbooks Limited by available memory 
and system resources 

Worksheet size 65,536 rows by 256 columns 
Column width 255 characters 
Row height 409 points 
Page breaks 1000 horizontal and vertical 

Length of cell contents (text) 
32,767 characters. Only 1,024 
display in a cell; all 32,767 
display in the formula bar. 

Sheets in a workbook Limited by available memory 
(default is 3 sheets) 

Colors in a workbook 56 
Cell styles in a workbook 4,000 
Named views (view: A set of display and print settings that you can name 
and apply to a workbook. You can create more than one view of the same 
workbook without saving separate copies of the workbook.) in a 
workbook 

Limited by available memory 

Custom number formats Limited by available memory 
Names in a workbook Limited by available memory 
Windows in a workbook Limited by system resources 
Panes in a window 4 
Linked sheets Limited by available memory 

Scenarios (scenario: A named set of input values that you can substitute in 
a worksheet model.)

Limited by available memory; 
a summary report shows only 
the first 251 scenarios 

Changing cells in a scenario 32 
Adjustable cells in Solver 200 
Custom functions Limited by available memory 
Zoom range 10 percent to 400 percent 
Reports Limited by available memory 

Sort references 3 in a single sort; unlimited 
when using sequential sorts 

Undo levels 16 
Fields in a data form 32 
Custom toolbars in a workbook Limited by available memory 
Custom toolbar buttons Limited by available memory 
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Workgroup specifications 

Feature Maximum limit 
Users who can open and share a shared workbook (shared workbook: A 
workbook set up to allow multiple users on a network to view and make 
changes at the same time. Each user who saves the workbook sees the 
changes made by other users.) at the same time 

256 

Personal views (view: A set of display and print settings that you can 
name and apply to a workbook. You can create more than one view of 
the same workbook without saving separate copies of the workbook.) in 
a shared workbook 

Limited by available memory 

Days that change history (change history: In a shared workbook, 
information that is maintained about changes made in past editing 
sessions. The information includes the name of the person who made 
each change, when the change was made, and what data was changed.) is 
maintained 

32,767 (default is 30 days) 

Workbooks that can be merged at one time Limited by available memory 
Cells that can be highlighted in a shared workbook 32,767 

Colors used to identify changes made by different users when change 
highlighting is turned on 

32 (each user is identified by a 
separate color; changes made 
by the current user are 
highlighted with navy blue) 

Calculation specifications 

Feature Maximum limit 
Number precision 15 digits 
Largest number 
allowed to be 
typed into a cell 

9.99999999999999E+307 

Largest allowed 
positive number 1.79769313486231E+308 

Smallest allowed 
negative number -2.2250738585072E-308 

Smallest allowed 
positive number 2.229E-308 

Largest allowed 
negative number -1E-307 

Length of formula 
contents 1,024 characters 

Iterations 32,767 

Worksheet arrays 

Limited by available memory. Also, arrays cannot refer to entire columns. For 
example, an array cannot refer to the entire column C:C or to the range C1:C65536. 
However, an array can refer to the range C1:D65535 because the range is one row 
short of the maximum worksheet size and does not include the entire C or D column. 
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Selected ranges 2,048 
Arguments in a 
function 30 

Nested levels of 
functions 7 

Number of 
available 
worksheet 
functions 

329 

Earliest date 
allowed for 
calculation 

January 1, 1900 (January 1, 1904, if 1904 date system is used) 

Latest date 
allowed for 
calculation 

December 31, 9999 

Largest amount of 
time that can be 
entered 

9999:59:59 
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